加入收藏 | 设为首页 | 会员中心 | 我要投稿 西安站长网 (https://www.029zz.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

大数运算(大数加法and大数乘法)

发布时间:2020-12-24 16:03:54 所属栏目:大数据 来源:网络整理
导读:副标题#e# 大数模板 -- 万进制 为基础的 模板 #include algorithm#include stdlib.h#include cstring#include iostream#include stdio.h#define ll long long#define MAXN 10000#define DELD 4using namespace std;int a[MAXN];int b[MAXN];struct Bignum{

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 343602????Accepted Submission(s): 66660


Problem Description I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
?
Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
?
Output For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
?
Sample Input
  
  
   
   2
1 2
112233445566778899 998877665544332211
  
  
?
Sample Output
  
  
   
   Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 2222222222222221110
  
  

?附上代码

#include<stdio.h>
#include<string.h>

char a[100000];
char b[100000];
int c[1000000];
int x[100000];
int y[100000];
int z[100000];
int main()
{
	int T,k,l,p,len1,len2;
	while(~scanf("%d",&T))
	{
		p=1;
		while(T--)
		{
			i=0,j=0;
			memset(a,sizeof(a));
			memset(b,sizeof(b));
			memset(c,sizeof(c));
			memset(x,sizeof(x));
			memset(y,sizeof(y));
			memset(z,sizeof(z));
			scanf("%s",a);
			len1=strlen(a);
			scanf("%s",b);
			len2=strlen(b);
			j=len1>len2? len1:len2;
			for(k=0,len1--;len1>=0;len1--)  //  a,b  倒 过来 
				x[k++]=a[len1]-'0';
			for(l=0,len2--;len2>=0;len2--)
				y[l++]=b[len2]-'0';
			// 计算
//			for(l=0;l<k;l++)
//				printf("%d",x[l]);
			for(i=0,l=0;i<j+1;i++)  // 运算x+y 
			{
				k=x[i]+y[i];
				c[i]=(k+l)%10;
				l=(k+l)/10;
			}
			printf("Case %d:n",p);
			printf("%s + %s = ",a,b);
			
			for(i--,l=0;i>=0;i--,l++)
				z[l]=c[i];
			for(i=0;i<l;i++)
			{
				if(i==0&&z[i]==0)
					i++;
				printf("%d",z[i]);
			}
			
//			for(i--;i>=0;i--)
//			{
//				if(c[i]==0)
//					i--;
//				printf("%d",c[i]);
//			}
			if(T==0)
				printf("n");
			else
				printf("nn");
			p++;
		}
		
	}
	return 0;
}

大数运算(大数加法and大数乘法)

(编辑:西安站长网)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

热点阅读